Локальные сети на основе коммутаторов

  1. Введение. Тенденция вытеснения концентраторов и маршрутизаторов коммутаторами
  2. Технологии коммутации кадров (frame switching) в локальных сетях
    • Ограничения традиционных технологий (Ethernet, Token Ring), основанных на разделяемых средах передачи данных
    • Локальные мосты - предшественники коммутаторов
    • Принципы коммутации сегментов и узлов локальных сетей, использующих традиционные технологии
    • Полнодуплексные (full-duplex) протоколы локальных сетей - ориентация исключительно на коммутацию кадров
  3. ATM-коммутация
  4. Особенности коммутаторов локальных сетей
    • Техническая реализация коммутаторов
      • Коммутаторы на основе коммутационной матрицы
      • Коммутаторы с общей шиной
      • Коммутаторы с разделяемой памятью
      • Комбинированные коммутаторы
      • Модульные и стековые коммутаторы
    • Характеристики производительности коммутаторов
      • Скорость фильтрации и скорость продвижения
      • Оценка необходимой общей производительности коммутатора
      • Размер адресной таблицы
      • Объем буфера
    • Дополнительные возможности коммутаторов
      • Трансляция протоколов канального уровня
      • Поддержка алгоритма Spanning Tree
      • Способы управления потоком кадров
      • Возможности коммутаторов по фильтрации трафика
      • Коммутация "на лету" или с буферизацией
      • Использование различных классов сервиса (class-of-service)
      • Поддержка виртуальных сетей
  5. Управление коммутируемыми сетями
  6. Типовые схемы применения коммутаторов в локальных сетях
    • Коммутатор или концентратор?
    • Коммутатор или маршрутизатор?
    • Стянутая в точку магистраль на коммутаторе
    • Распределенная магистраль на коммутаторах
  7. Обзор моделей коммутаторов
    • Коммутаторы Catalyst компании Cisco Systems
    • Коммутатор EliteSwitch ES/1 компании SMC
    • Коммутаторы локальных сетей компании 3Com
    • Примеры АТМ-коммутаторов для локальных сетей
      • Коммутаторы CELLplex компании 3Com
      • Коммутаторы технологии ATM LattisCell и EtherCell компании Bay Networks
      • Коммутатор LightStream 1010 компании Cisco
  8. Тестовые испытания коммутаторов


Введение. Тенденция вытеснения концентраторов и маршрутизаторов коммутаторами

Транспортная система локальных сетей масштаба здания или кампуса уже достаточно давно стала включать разнообразные типы активного коммуникационного оборудования - повторители, концентраторы, коммутаторы и маршрутизаторы, соединенные в сложные иерархические структуры, вроде той, которая изображена на рисунке 1.1.

Рис. 1.1. Типичная структура сети здания или кампуса

Активное оборудование управляет циркулирующими в сети битами, кадрами и пакетами, стараясь организовать их передачу так, чтобы данные терялись как можно реже, а попадали к адресатам как можно быстрее, в соответствии с потребностями трафика работающих в сети приложений.

Описанный подход стал нормой при проектировании крупных сетей и полностью вытеснил сети, построенные исключительно на основе пассивных сегментов кабеля, которыми совместно пользуются для передачи информации компьютеры сети. Преимущества сетей с иерархически соединенным активным оборудованием не раз проверены на практике и сейчас никем не оспариваются.

И, если не обращать внимание на типы используемого оборудования, а рассматривать их просто как многопортовые черные ящики, то может сложиться впечатление, что никаких других изменений в теории и практике построения локальных сетей нет - предлагаются и реализуются очень похожие схемы, отличающиеся только количеством узлов и уровней иерархии коммуникационного оборудования.

Однако, качественный анализ используемого оборудования говорит об обратном. Изменения есть, и они существенны. За последние год-два коммутаторы стали заметно теснить другие виды активного оборудования с казалось бы прочно завоеванных позиций. Несколько лет назад в типичной сети здания нижний уровень иерархии всегда занимали повторители и концентраторы, верхний строился с использованием маршрутизаторов, а коммутаторам отводилось место где-то посередине, на уровне сети этажа. К тому же, коммутаторов обычно было немного - их ставили только в очень загруженные сегменты сети или же для подключения сверхпроизводительных серверов.

Коммутаторы стали вытеснять маршрутизаторы из центра сети на периферию (рисунок 1.2), где они использовались для соединения локальной сети с глобальными.

Рис. 1.2. Совместное использование коммутаторов и маршрутизаторов

Центральное место в сети здания занял модульный корпоративный коммутатор, который объединял на своей внутренней, как правило, очень производительной, магистрали все сети этажей и отделов. Коммутаторы потеснили маршрутизаторы потому, что их показатель "цена/производительность", рассчитанный для одного порта, оказался гораздо ниже при приближающихся к маршрутизаторам функциональным возможностям по активному воздействию на передаваемый трафик. Сегодняшние корпоративные коммутаторы умеют многое из того, что несколько лет назад казалось исключительной прерогативой маршрутизаторов: транслировать кадры разных технологий локальных сетей, например Ethernet в FDDI, осуществлять фильтрацию трафика по различным условиям, в том числе и задаваемым пользователем, изолировать трафик одного сегмента от другого и т.п. Коммутаторы ввели также и новую технологию, которая до их появления не применялась - технологию виртуальных сегментов, позволяющих перемещать пользователей из одного сегмента в другой чисто программным путем, без физической перекоммутации разъемов. И при всем при этом стоимость за один порт при равной производительности у коммутаторов оказывается в несколько раз ниже, чем у маршрутизаторов.

После завоевания магистрального уровня корпоративной сети коммутаторы начали наступление на сети рабочих групп, где до этого в течение последних пяти лет всегда использовались многопортовые повторители (концентраторы) для витой пары, заменившие пассивные коаксиальные сегменты. Появились коммутаторы, специально предназначенные для этой цели - простые, часто неуправляемые устройства, способные только быстро передавать кадры с порта на порт по адресу назначения, но не поддерживающие всей многофункциональности корпоративных коммутаторов. Стоимость таких коммутаторов в расчете на один порт быстро снижается и, хотя порт концентратора по-прежнему стоит меньше порта коммутатора рабочей группы, тенденция к сближению их цен налицо.

Подтверждением этой тенденции могут служить данные исследовательских компаний InStat и Dell'Oro Group за 1996 год и их прогноз на 1998 год:
1996 1998 Процент снижения
за два года
Средняя цена за порт концентратора
Ethernet | $101 | $94 | 6.9%
Fast Ethernet | $200 | $145 | 27.5%
Средняя цена за порт коммутатора
Ethernet | $427 | $200 | 53%
Fast Ethernet | $785 | $500 | 36.3%
Отношение порт коммутатора/порт концентратора
Ethernet 4.22 2.1
Fast Ethernet 3.9 3.4

Эти данные собраны по всем классам коммутаторов, от уровня рабочей группы до магистрального уровня, где концентраторы не применяются, поэтому сопоставление концентраторов только с коммутаторами рабочих групп дало бы еще более близкие в стоимостном отношении результаты, так как стоимость за порт Ethernet у отдельных коммутаторов доходит до $150, то есть всего в полтора раза превышает стоимость порта концентратора Ethernet.

В то же время производительность сети, построенной на коммутаторе, обычно в несколько раз превышает производительность аналогичной сети, построенной с использованием концентратора. Так как плата за повышение производительности не так уж велика и постоянно снижается, то многие сетевые интеграторы все чаще соглашаются с ней для снижения задержек в своей сети. С распространением работающих в реальном времени приложений ущерб от транспортных задержек становится все ощутимее, а нагрузка на транспортную систему возрастает, что еще больше стимулирует приближение таких высокопроизводительных устройств, как коммутаторы, к пользовательским компьютерам.

Естественно, тенденция повышения роли коммутаторов в локальных сетях не имеет абсолютного характера. И у маршрутизаторов, и у концентраторов по-прежнему имеются свои области применения, где их применение более рационально, чем коммутаторов. Маршрутизаторы остаются незаменимыми при подключении локальной сети к глобальной. Кроме того, маршрутизаторы хорошо дополняют коммутаторы при построении виртуальных сетей из виртуальных сегментов, так как дают испытанный способ объединения сегментов в сеть на основании их сетевых адресов.

Концентраторы также имеют сегодня свою нишу. По-прежнему существует большое количество случаев, когда трафик в рабочей группе невелик и направлен к одному серверу. В таких случаях высокая производительность коммутатора мало что дает конечному пользователю - при замене концентратора на коммутатор он ее практически не почувствует.

Тем не менее, в локальных сетях появляется все больше коммутаторов, и эта ситуация вряд ли коренным образом изменится в ближайшем будущем. Некоторые новые технологии, такие как ATM, вообще используют коммутацию как единственный способ передачи данных в сети, другие, например, Gigabit Ethernet - рассматривают ее в качестве, хотя и не единственного, но основного способа связи устройств в сети.


Технологии коммутации кадров (frame switching) в локальных сетях

Ограничения традиционных технологий (Ethernet, Token Ring), основанных на разделяемых средах передачи данных

Повторители и концентраторы локальных сетей реализуют базовые технологии, разработанные для разделяемых сред передачи данных. Классическим представителем такой технологии является технология Ethernet на коаксиальном кабеле. В такой сети все компьютеры разделяют во времени единственный канал связи, образованный сегментом коаксиального кабеля (рисунок 2.1).

Рис. 2.1. Разделяемый канал передачи данных в сети Ethernet

При передаче каким-нибудь компьютером кадра данных все остальные компьютеры принимают его по общему коаксиальному кабелю, находясь с передатчиком в постоянном побитном синхронизме. На время передачи этого кадра никакие другие обмены информации в сети не разрешаются. Способ доступа к общему кабелю управляется несложным распределенным механизмом арбитража - каждый компьютер имеет право начать передачу кадра, если на кабеле отсутствуют информационные сигналы, а при одновременной передаче кадров несколькими компьютерами схемы приемников умеют распознавать и обрабатывать эту ситуацию, называемую коллизией. Обработка коллизии также несложна - все передающие узлы прекращают выставлять биты своих кадров на кабель и повторяют попытку передачи кадра через случайный промежуток времени.

Работа всех узлов сети Ethernet в режиме большой распределенной электронной схемы с общим тактовым генератором приводит к нескольким ограничениям, накладываемым на сеть. Основными ограничениями являются:

  • Максимально допустимая длина сегмента. Она зависит от типа используемого кабеля: для витой пары это 100 м, для тонкого коаксиала - 185 м, для толстого коаксиала - 500 м, а для оптоволокна - 2000 м. Для наиболее дешевых и распространенных типов кабеля - витой пары и тонкого коаксиала - это ограничение часто становится весьма нежелательным. Технология Ethernet предлагает использовать для преодоления этого ограничения повторители и концентраторы, выполняющие функции усиления сигнала, улучшения формы фронтов импульсов и исправления погрешностей синхронизации. Однако возможности этих устройств по увеличению максимально допустимого расстояния между двумя любыми узлами сети (которое называется диаметром сети) не очень велики - число повторителей между узлами не может превышать 4-х (так называемое правило четырех хабов). Для витой пары это дает увеличение до 500 м (рисунок 2.2). Кроме того, существует общее ограничение на диаметр сети Ethernet - не более 2500 м для любых типов кабеля и любого количества установленных концентраторов. Это ограничение нужно соблюдать для четкого распознавания коллизий всеми узлами сети, как бы далеко (в заданных пределах) они друг от друга не находились, иначе кадр может быть передан с искажениями.

Рис. 2.2. Максимальный диаметр сети Ethernet на витой паре

  • Максимальное число узлов в сети. Стандарты Ethernet ограничивают число узлов в сети предельным значением в 1024 компьютера вне зависимости от типа кабеля и количества сегментов, а каждая спецификация для конкретного типа кабельной системы устанавливает еще и свое, более жесткое ограничение. Так, к сегменту кабеля на тонком коаксиале нельзя подключить более 30 узлов, а для толстого коаксиала это число увеличивается до 100 узлов. В сетях Ethernet на витой паре и оптоволокне каждый отрезок кабеля соединяет всего два узла, но так как количество таких отрезков спецификация не оговаривает, то здесь действует общее ограничение в 1024 узла.

Существуют также и другие причины, кроме наличия указанных в стандартах ограничений, по которым число узлов в сети Ethernet обычно не превосходит нескольких десятков. Эти причины лежат в самом принципе разделения во времени одного канала передачи данных между всеми узлами сети. При подключении к такому каналу каждый узел пользуется его пропускной способностью - 10 Мб/с - в течение только некоторой доли общего времени работы сети. Соответственно, на узел приходится эта же доля пропускной способности канала. Даже если упрощенно считать, что все узлы получают равные доли времени работы канала и непроизводительные потери времени отсутствуют, то при наличии в сети N узлов на один узел приходится только 10/N Мб/с пропускной способности. Очевидно, что при больших значениях N пропускная способность, выделяемая каждому узлу, оказывается настолько малой величиной, что нормальная работа приложений и пользователей становится невозможной - задержки доступа к сетевым ресурсам превышают тайм-ауты приложений, а пользователи просто отказываются так долго ждать отклика сети.

Случайный характер алгоритма доступа к среде передачи данных, принятый в технологии Ethernet, усугубляет ситуацию. Если запросы на доступ к среде генерируются узлами в случайные моменты времени, то при большой их интенсивности вероятность возникновения коллизий также возрастает и приводит к неэффективному использованию канала: время обнаружения коллизии и время ее обработки составляют непроизводительные затраты. Доля времени, в течение которого канал предоставляется в распоряжение конкретному узлу, становится еще меньше.

На рисунке 2.3 показана зависимость задержек доступа к среде передачи данных в сети Ethernet от количества узлов сети. Экспоненциальный рост задержек при увеличении числа узлов очень характерен как для технологии Ethernet, так и для других технологий локальных сетей, основанных на разделении каналов во времени - Token Ring, FDDI, 100VG-AnyLAN.

Рис. 2.3. Зависимость задержек доступа к среде передачи данных
сети Ethernet от числа узлов сети

До недавнего времени в локальных сетях редко использовались мультимедийные приложения, перекачивающие большие файлы данных, нередко состоящие из нескольких десятков мегабайт. Приложения же, работающие с алфавитно-цифровой информацией, не создавали значительного трафика. Поэтому долгое время для сегментов Ethernet было действительным эмпирическое правило - в разделяемом сегменте не должно быть больше 30 узлов. Теперь ситуация изменилась и нередко 3-4 компьютера полностью загружают сегмент Ethernet с его максимальной пропускной способностью в 10 Мб/с или же 14880 кадров в секунду.

Более универсальным критерием загруженности сегмента Ethernet по сравнению с общим количеством узлов является суммарная нагрузка на сегмент, создаваемая его узлами. Если каждый узел генерирует в среднем mi кадров в секунду для передачи по сети, то средняя суммарная нагрузка на сеть будет составлять Si mi кадров в секунду. Известно, что при отсутствии коллизий, то есть при самом благоприятном разбросе запросов на передачу кадров во времени, сегмент Ethernet может передать не больше 14880 кадров в секунду (для самых коротких по стандарту кадров в 64 байта). Поэтому, если принять эту величину за единицу, то отношение Si mi/14880 будет характеризовать степень использования канала, называемый также коэффициентом загрузки.

Зависимость времени ожидания доступа к сети от коэффициента загрузки гораздо меньше зависит от интенсивности трафика каждого узла, поэтому эту величину удобно использовать для оценки пропускной способности сети, состоящей из произвольного числа узлов. Имитационное моделирование сети Ethernet и исследование ее работы с помощью анализаторов протоколов показали, что при коэффициенте загрузки в районе 0.3 - 0.5 начинается быстрый рост числа коллизий и соответственно времени ожидания доступа. Поэтому во многих системах управления сетями пороговая граница для индикатора коэффициента загрузки по умолчанию устанавливается на величину 0.3.

Ограничения, связанные с возникающими коллизиями и большим временем ожидания доступа при значительной загрузке разделяемого сегмента, чаще всего оказываются более серьезными, чем ограничение на максимальное количество узлов, определенное в стандарте из соображений устойчивой передачи электрических сигналов в кабелях.

Технология Ethernet была выбрана в качестве примера при демонстрации ограничений, присущих технологиям локальных сетей, так как в этой технологии ограничения проявляются наиболее ярко, а их причины достаточно очевидны. Однако подобные ограничения присущи и всем остальным технологиям локальных сетей, так как они опираются на использование среды передачи данных как одного разделяемого ресурса. Кольца Token Ring и FDDI также могут использоваться узлами сети только в режиме разделяемого ресурса. Отличие от канала Ethernet здесь состоит только в том, что маркерный метод доступа определяет детерминированную очередность предоставления доступа к кольцу, но по-прежнему при предоставлении доступа одного узла к кольцу все остальные узлы не могут передавать свои кадры и должны ждать, пока владеющий правом доступа узел не завершит свою передачу.

Как и в технологии Ethernet, в технологиях Token Ring, FDDI, Fast Ethernet и 100VG-AnyLAN также определены максимальные длины отдельных физических сегментов кабеля и ограничения на максимальный диаметр сети и максимальное количество в ней узлов. Эти ограничения несколько менее стеснительны, чем у технологии Ethernet, но также могут быть серьезным препятствием при создании крупной сети.

Особенно же быстро может проявиться ограничение, связанное с коэффициентом загрузки общей среды передачи данных. Хотя метод маркерного доступа, используемый в технологиях Token Ring и FDDI, или метод приоритетных требований технологии 100VG-AnyLAN позволяют работать с более загруженными средами, все равно отличия эти только количественные - резкий рост времени ожидания начинается в таких сетях при больших коэффициентах загрузки, где-то в районе 60% - 70%. Качественный характер нарастания времени ожидания доступа и в этих технологиях тот же, и он не может быть принципиально иным, когда общая среда передачи данных разделяется во времени между компьютерами сети.

Общее ограничение локальных сетей, построенных только с использованием повторителей и концентраторов, состоит в том, что общая производительность такой сети всегда фиксирована и равна максимальной производительности используемого протокола. И эту производительность можно повысить только перейдя к другой технологии, что связано с дорогостоящей заменой всего оборудования.

Рассмотренные ограничения являются платой за преимущества, которые дает использование разделяемых каналов в локальных сетях. Эти преимущества существенны, недаром технологии такого типа существуют уже около 20 лет.

К преимуществам нужно отнести в первую очередь:

  • простоту топологии сети;
  • гарантию доставки кадра адресату при соблюдении ограничений стандарта и корректно работающей аппаратуре;
  • простоту протоколов, обеспечившую низкую стоимость сетевых адаптеров, повторителей и концентраторов;

Однако начавшийся процесс вытеснения повторителей и концентраторов коммутаторами говорит о том, что приоритеты изменились, и за повышение общей пропускной способности сети пользователи готовы пойти на издержки, связанные с приобретением коммутаторов вместо концентраторов.


Управление коммутируемыми сетями

Коммутаторы - это сложные многофункциональные устройства, играющие ответственную роль в современных сетях. Поэтому поддержка функций централизованного контроля и управления, реализуемого протоколом SNMP и соответствующими агентами, практически обязательна для всех классов коммутаторов (кроме, может быть, настольных коммутаторов, предназначенных для работы в очень маленьких сетях).

Для поддержки SNMP-управления коммутаторы имеют модуль управления, в котором имеется агент, ведущий базу данных управляющей информации. Этот модуль часто выполняется на отдельном мощном процессоре, чтобы не замедлять основные операции коммутатора.

Наблюдение за трафиком

Так как перегрузки процессоров портов и других обрабатывающих элементов коммутатора могут приводить к потерям кадров, то функция наблюдения за распределением трафика в сети, построенной на основе коммутаторов, очень важна.

Однако, если сам коммутатор не имеет отдельного агента для каждого своего порта, то задача слежения за трафиком, традиционно решаемая в сетях с разделяемыми средами с помощью установки в сеть внешнего анализатора протоколов, очень усложняется.

Обычно в традиционных сетях анализатор протоколов (например, Sniffer компании Network General) подключался к свободному порту концентратора и видел весь трафик, передаваемый между любыми узлами сети.

Если же анализатор протокола подключить к свободному порту коммутатора, то он не увидит почти ничего, так как ему кадры передавать никто не будет, а чужие кадры в его порт также направляться не будут. Единственный вид трафика, который будет видеть анализатор - это трафик широковещательных пакетов, которые будут передаваться всем узлам сети. В случае, когда сеть разделена на виртуальные сети, анализатор протоколов будет видеть только широковещательный трафик своей виртуальной сети.

Для того, чтобы анализаторами протоколов можно было по-прежнему пользоваться и в коммутируемых сетях, производители коммутаторов снабжают свои устройства функцией зеркального отображения трафика любого порта на специальный порт. К специальному порту подключается анализатор протоколов, а затем на коммутатор подается команда через его модуль SNMP-управления для отображения трафика какого-либо порта на специальный порт.

Наличие функции зеркализации портов частично снимает проблему, но оставляет некоторые вопросы. Например, как просмотреть одновременно трафик двух портов, или как просматривать трафик порта, работающего в полнодуплексном режиме.

Более надежным способом слежения за трафиком, проходящим через порты коммутатора, является замена анализатора протокола на агенты RMON MIB для каждого порта коммутатора.

Агент RMON выполняет все функции хорошего анализатора протокола для протоколов Ethernet и Token Ring, собирая детальную информацию об интенсивности трафика, различных типах плохих кадров, о потерянных кадрах, причем самостоятельно строя временные ряды для каждого фиксируемого параметра. Кроме того, агент RMON может самостоятельно строить матрицы перекрестного трафика между узлами сети, которые очень нужны для анализа эффективности применения коммутатора.

Так как агент RMON, реализующий все 9 групп объектов Ethernet, стоит весьма дорого, то производители для снижения стоимости коммутатора часто реализуют только первые несколько групп объектов RMON MIB.

Управление виртуальными сетями

Виртуальные сети порождают проблемы для традиционных систем управления на SNMP-платформе как при их создании, так и при наблюдении за их работой.

Как правило, для создания виртуальных сетей требуется специальное программное обеспечение компании-производителя, которое работает на платформе системы управления, такой как, например, HP Open View. Сами платформы систем управления этот процесс поддержать не могут, в основном из-за отсутствия стандарта на виртуальные сети. Можно надеяться, что появление стандарта 802.1Q изменит ситуацию в этой области.

Наблюдение за работой виртуальных сетей также создает проблемы для традиционных систем управления. При создании карты сети, включающей виртуальные сети, необходимо отображать как физическую структуру сети, так и ее логическую структуру, соответствующую связям отдельных узлов виртуальной сети. При этом по желанию администратора система управления должна уметь отображать соответствие логических и физических связей в сети, то есть на одном физическом канале должны отображаться все или отдельные пути виртуальных сетей.

К сожалению, многие системы управления либо вообще не отображают виртуальные сети, либо делают это очень неудобным для пользователя способом.


Типовые схемы применения коммутаторов в локальных сетях

Коммутатор или концентратор?

При построении небольших сетей, составляющих нижний уровень иерархии корпоративной сети, вопрос о применении того или иного коммуникационного устройства сводится к вопросу о выборе между концентратором или коммутатором.

При ответе на этот вопрос нужно принимать во внимание несколько факторов. Безусловно, немаловажное значение имеет стоимость за порт, которую нужно заплатить при выборе устройства. Из технических соображений в первую очередь нужно принять во внимание существующее распределение трафика между узлами сети. Кроме того, нужно учитывать перспективы развития сети: будут ли в скором времени применяться мультимедийные приложения, будет ли модернизироваться компьютерная база. Если да, то нужно уже сегодня обеспечить резервы по пропускной способности применяемого коммуникационного оборудования. Использование технологии intranet также ведет к увеличению объемов трафика, циркулирующего в сети, и это также необходимо учитывать при выборе устройства.

При выборе типа устройства - концентратор или коммутатор - нужно еще определить и тип протокола, который будут поддерживать его порты (или протоколов, если идет речь о коммутаторе, так как каждый порт может поддерживать отдельный протокол).

Сегодня выбор делается между протоколами двух скоростей - 10 Мб/с и 100 Мб/с. Поэтому, сравнивая применимость концентратора или коммутатора, необходимо рассмотреть вариант концентратора с портами на 10 Мб/с, вариант концентратора с портами на 100 Мб/c, и несколько вариантов коммутаторов с различными комбинациями скоростей на его портах.

Техника применения матрицы перекрестного трафика для анализа эффективности применения коммутатора уже была рассмотрена в разделе 4.2.2. Пользуясь ею, можно оценить, сможет ли коммутатор с известными пропускными способностями портов и общей производительностью поддержать трафик в сети, заданный в виде матрицы средних интенсивностей трафика.

Рассмотрим теперь эту технику для ответа на вопрос о применимости коммутатора в сети с одним сервером и несколькими рабочими станциями, взаимодействующими только с сервером (рисунок 6.1). Такая конфигурация сети часто встречается в сетях масштаба рабочей группы, особенно в сетях NetWare, где стандартные клиентские оболочки не могут взаимодействовать друг с другом.

Матрица перекрестного трафика для такой сети имеет вырожденный вид. Если сервер подключен, например, к порту 4, то только 4-я строка матрицы и 4-ый столбец матрицы будут иметь отличные от нуля значения. Эти значения соответствуют выходящему и входящему трафику порта, к которому подключен сервер. Поэтому условия применимости коммутатора для данной сети сводятся к возможности передачи всего трафика сети портом коммутатора, к которому подключен сервер.

Если коммутатор имеет все порты с одинаковой пропускной способностью, например, 10 Мб/c, то в этом случае пропускная способность порта в 10 Мб/c будет распределяться между всеми компьютерами сети. Возможности коммутатора по повышению общей пропускной способности сети оказываются для такой конфигурации невостребованными. Несмотря на микросегментацию сети, ее пропускная способность ограничивается пропускной способностью протокола одного порта, как и в случае применения концентратора с портами 10 Мб/с. Небольшой выигрыш при использовании коммутатора будет достигаться лишь за счет уменьшения количества коллизий - вместо коллизий кадры будут просто попадать в очередь к передатчику порта коммутатора, к которому подключен сервер.

Рис. 6.1. Сеть с выделенным сервером

Для того, чтобы коммутатор работал в сетях с выделенным сервером более эффективно, производители коммутаторов выпускают модели с одним высокоскоростным портом на 100 Мб/с для подключения сервера и несколькими низкоскоростными портами на 10 Мб/с для подключения рабочих станций. В этом случае между рабочими станциями распределяется уже 100 Мб/c, что позволяет обслуживать в неблокирующем режиме 10 - 30 станций, в зависимости от интенсивности создаваемого ими трафика.

Однако с таким коммутатором может конкурировать концентратор, поддерживающий протокол с пропускной способностью 100 Мб/с, например, Fast Ethernet. Стоимость его за порт будет несколько ниже стоимости за порт коммутатора с одним высокоскоростным портом, а производительность сети примерно та же.

Очевидно, что выбор коммуникационного устройства для сети с выделенным сервером достаточно сложен. Для принятия окончательного решения нужно принимать во внимание перспективы развития сети в отношении движения к сбалансированному трафику. Если в сети вскоре может появиться взаимодействие между рабочими станциями, или же второй сервер, то выбор необходимо делать в пользу коммутатора, который сможет поддержать дополнительный трафик без ущерба по отношению к основному.

В пользу коммутатора может сыграть и фактор расстояний - применение коммутаторов не ограничивает максимальный диаметр сети величинами в 2500 м или 210 м, которые определяют размеры домена коллизий при использовании концентраторов Ethernet и Fast Ethernet.


Коммутатор или маршрутизатор?

При построении верхних, магистральных уровней иерархии корпоративной сети проблема выбора формулируется по-другому - коммутатор или маршрутизатор?

Коммутатор выполняет передачу трафика между узлами сети быстрее и дешевле, зато маршрутизатор более интеллектуально отфильтровывает трафик при соединении сетей, не пропуская ненужные или плохие пакеты, а также надежно защищая сети от широковещательных штормов.

В связи с тем, что коммутаторы корпоративного уровня могут поддерживать некоторые функции сетевого уровня, выбор все чаще делается в пользу коммутатора. При этом маршрутизатор также используется, но он часто остается в локальной сети в единственном экземпляре. Этот маршрутизатор обычно служит и для связи локальной сети с глобальными, и для объединения виртуальных сетей, построенных с помощью коммутаторов.

В центре же сетей зданий и этажей все чаще используются коммутаторы, так как только при их использовании возможно осуществить передачу нескольких гигабит информации в секунду за приемлемую цену (рисунок 1.2).


Стянутая в точку магистраль на коммутаторе

При всем разнообразии структурных схем сетей, построенных на коммутаторах, все они используют две базовые структуры - стянутую в точку магистраль и распределенную магистраль. На основе этих базовых структур затем строятся разнообразные структуры конкретных сетей.

Стянутая в точку магистраль (collapsed backbone) - это структура, при которой объединение узлов, сегментов или сетей происходит на внутренней магистрали коммутатора. Пример сети рабочей группы, использующей такую структуру, приведен на рисунке 6.2.

Рис. 6.2. Структура сети со стянутой в точку магистралью

Преимуществом такой структуры является высокая производительность магистрали. Так как для коммутатора производительность внутренней шины или схемы общей памяти, объединяющей модули портов, в несколько Гб/c не является редкостью, то магистраль сети может быть весьма быстродействующей, причем ее скорость не зависит от применяемых в сети протоколов и может быть повышена с помощью замены одной модели коммутатора на другую.

Положительной чертой такой схемы является не только высокая скорость магистрали, но и ее протокольная независимость. На внутренней магистрали коммутатора в независимом формате одновременно могут передаваться данные различных протоколов, например, Ethernet, FDDI и Fast Ethernet, как это изображено на рисунке. Подключение нового узла с новым протоколом часто требует не замены коммутатора, а просто добавления соответствующего интерфейсного модуля, поддерживающего этот протокол.

Если к каждому порту коммутатора в такой схеме подключен только один узел, то такая схема будет соответствовать микросегментированной сети.


Распределенная магистраль на коммутаторах

В сетях больших зданий или кампусов использование структуры с коллапсированной магистралью не всегда рационально или же возможно. Такая структура приводит к протяженным кабельным системам, которые связывают конечные узлы или коммутаторы сетей рабочих групп с центральным коммутатором, шина которого и является магистралью сети. Высокая плотность кабелей и их высокая стоимость ограничивают применение стянутой в точку магистрали в таких сетях. Иногда, особенно в сетях кампусов, просто невозможно стянуть все кабели в одно помещение из-за ограничений на длину связей, накладываемых технологией (например, все реализации технологий локальных сетей на витой паре ограничивают протяженность кабелей в 100 м).

Поэтому в локальных сетях, покрывающих большие территории, часто используется другой вариант построения сети - с распределенной магистралью. Пример такой сети приведен на рисунке 6.3.

Распределенная магистраль - это разделяемый сегмент сети, поддерживающий определенный протокол, к которому присоединяются коммутаторы сетей рабочих групп и отделов. На примере распределенная магистраль построена на основе двойного кольца FDDI, к которому подключены коммутаторы этажей. Коммутаторы этажей имеют большое количество портов Ethernet, трафик которых транслируется в трафик протокола FDDI, когда он передается по магистрали с этажа на этаж.

Рис. 6.3. Структура сети с распределенной магистралью

Распределенная магистраль упрощает связи между этажами, сокращает стоимость кабельной системы и преодолевает ограничения на расстояния.

Однако, скорость магистрали в этом случае будет существенно меньше скорости магистрали на внутренней шине коммутатора. Причем скорость эта фиксированная и не превышает в настоящее время 100 Мб/c. Поэтому распределенная магистраль может применяться только при невысокой интенсивности трафика между этажами или зданиями.

Пример рисунка 6.3 демонстрирует сочетание использования двух базовых структур, так как на каждом этаже сеть построена с использованием магистрали на внутренней шине коммутатора.


Обзор моделей коммутаторов

Рынок коммутаторов сегодня очень обширен, поэтому в этом кратком обзоре остановимся только на некоторых популярных моделях коммутаторов различного класса. Обычно коммутаторы делят в первую очередь на классы в соответствии с их областями применения - настольные коммутаторы, коммутаторы рабочих групп, коммутаторы отделов и магистральные (корпоративные коммутаторы). У каждого класса коммутаторов есть свои отличительные признаки.

Настольные коммутаторы

  • Фиксированное количество портов;
  • Все порты работают на одной скорости;
  • Используются для организации одноранговых связей высокоскоростных рабочих станций;
  • Режим коммутации - "на лету";
  • Чаще всего не содержат модуля SNMP-управления, а также не поддерживают алгоритм Spanning Tree.

Пример: 3Com LinkSwitch 500.

Коммутаторы рабочих групп

  • Имеют по крайней мере 1 высокоскоростной порт (FDDI, Fast Ethernet, ATM);
  • Транслируют протоколы;
  • Как правило, управляемы по SNMP, поддерживают алгоритм Spanning Tree;
  • Режим коммутации - с буферизацией.

Примеры: семейство 3Com LinkSwitch (кроме модели 500), SMC TigerSwitch XE, Bay Networks Ethernet Workgroup Switch.

Коммутаторы отделов и центров обработки данных

  • Модульное исполнение;
  • Поддержка нескольких протоколов;
  • Встроенные средства обеспечения отказоустойчивости:
  • избыточные источники питания;
  • модули hot-swap.
  • Пользовательские фильтры;
  • Поддержка виртуальных сегментов;

Примеры: 3Com LANplex 2500, SMC ES/1, Bay Networks LattisSwitch System 28115.

Коммутаторы магистралей зданий/кампусов

  • Те же свойства, что и у коммутаторов отделов;
  • Шасси с большим количеством слотов (10 - 14);
  • Внутренняя пропускная способность 1 - 10 Гб/с;
  • Поддержка 1 - 2 протоколов маршрутизации (локальные интерфейсы) для образования виртуальных сетей.

Примеры: 3Com LANplex 6000, Cabletron MMAC Plus, LANNET LET-36, Cisco Catalist 5000, Bay Networks System 5000.


Коммутаторы Catalyst компании Cisco Systems

Коммутатор Catalyst 5000 представляет собой старшую модель семейства Catalyst. Это модульная, многоуровневая платформа коммутации, которая обеспечивает высокий уровень производительности, предоставляя возможность как для создания выделенных соединений в сети Ethernet со скоростями 10 и 100 Mб/с, так и для организации взаимодействия с сетями FDDI и АТМ.

Шасси Catalyst 5000 имеет 5 разъемов. В один разъем устанавливается модуль управления Supervisor Engine, который управляет доступом к коммутируемой матрице, имеющей возможность коммутации более 1 млн. пакетов в секунду. Модуль поддерживает функции локального и удаленного управления и имеет два порта Fast Ethernet, которые могут использоваться для соединения серверов сети или каскадирования устройств Catalyst 5000. Остальные разъемы могут использоваться для установки следующих модулей:

  • 24 порта 10Base-T;
  • 12 портов 10Base-FL;
  • 12 портов 100Base -TX;
  • 12 портов 100Base-FX;
  • 1 порт DAS CDDI/FDDI (не более 3-х модулей в шасси);
  • 1 порт 155 Мб/с АТМ (не более 3-х модулей в шасси).

Одно устройство Catalyst 5000 может поддерживать до 96 коммутируемых портов Ethernet и до 50 коммутируемых портов Fast Ethernet.

Поддерживается формирование виртуальных сетей как в пределах одного устройства Catalyst 5000, так и для нескольких устройств на основе группирования портов. Можно создать до 1000 виртуальных сетей для нескольких устройств Catalyst 5000, соединенных интерфейсами Fast Ethernet, CDDI/FDDI или ATM. Любой интерфейс Fast Ethernet может быть сконфигурирован как интерфейс InterSwitch Link (ISL) для поддержки нескольких виртуальных сетей. Интерфейс ISL - частное решение компании Cisco для передачи информации между коммутаторами о виртуальных сетях.

Все виртуальные сети поддерживают протокол IEEE 802.1d Spanning Tree для обеспечения отказоустойчивых соединений. При использовании интерфейса АТМ для соединения коммутаторов поддержка виртуальных сетей осуществляется на основе спецификации LANE через виртуальные соединения. Интерфейс FDDI поддерживает виртуальные сети с помощью спецификации 802.10.

Отличительной особенностью коммутаторов Catalyst является выполнение коммутации на 3 уровне модели OSI, что позволяет объединять виртуальные сети внутри устройства (для этого требуется дополнительное программное обеспечение).

Модуль управления коммутацией поддерживает три уровня очередей кадров с различными приоритетами, причем приоритеты назначаются для каждого порта отдельно. Это позволяет эффективно обслуживать мультимедийный трафик.

Большой буфер (по 192 Кбайта на порт) обеспечивает сохранение и передачу информации при пиковых нагрузках.

Система Catalyst 3000 представляет собой оригинальную реализацию стековой архитектуры для коммутаторов. Эта архитектура поддерживается устройствами двух типов:

  • Коммутатор Catalyst 3000 c 16 портами 10Base-T, одним портом AUI и двумя слотами расширения. Модули расширения могут иметь либо 1 порт 100Base-TX, либо 3 порта 10Base-FL, либо 4 порта 10Base-T, либо 1 порт ATM. Порт мониторинга осуществляет зекрализацию любого порта данных на внешний порт.
  • Catalyst Matrix - 8-ми портовая матрица коммутация, с помощью которой можно объединить в стек до 8 коммутаторов Catalyst 3000 для создания единого коммутирующего центра.

Коммутаторы Catalyst 3000 подключаются к Catalyst Matrix через специальные 280 Мб/с порты. Производительность шины Catalyst Matryx составляет 3.84 Гб/с.

Коммутатор работает под управлением IOS и использует два алгоритма коммутации - cut-throw и store-and-forward.

Стек Catalyst 3000 поддерживает до 64 виртуальных сетей и позволяет фильтровать трафик по адресу источника и адресу назначения. Максимальное число MAC-адресов - до 10К на устройство.

Поддерживается алгоритм Spanning Tree и SNMP-управление.


Коммутатор EliteSwitch ES/1 компании SMC

Корпорация SMC (сейчас ее подразделение коммутаторов является частью компании Cabletron) разработала коммутатор EliteSwitch ES/1 как эффективный инструмент для создания внутренней магистрали сети средних размеров. Коммутатор ES/1 сочетает в себе функции высокопроизводительного коммутатора технологий Ethernet/Token Ring/FDDI и локального маршрутизатора, позволяющего создавать виртуальные сети IP и IPX на основе виртуальных коммутируемых рабочих групп. Таким образом, в одном устройстве объединены функции switching и internetworking, необходимые для построения на базе внутренней скоростной шины структурированной локальной сети. Коммутатор поддерживает и глобальные связи с топологией "точка-точка" по линиям T1/E1, позволяя связывать несколько локальных сетей, построенных на его основе, друг с другом.

Рис. 7.1. Структура коммутатора ES/1

Коммутатор ES/1 работает по технологии коммутации с буферизацией, что позволяет ему транслировать протоколы канального уровня, осуществлять пользовательскую фильтрацию, сбор статистики и локальную маршрутизацию.

Организация коммутатора ES/1

Модульный концентратор ES/1 компании SMC (рисунок 7.1) представляет собой устройство в виде корпуса-шасси с задней коммуникационной платой, на которой выполнена внутренняя шина с производительностью 800 Мб/с. Блок обработки пакетов (Packet Processing Engine) включает в себя два процессорных модуля, оснащенных высокопроизводительными RISC-процессорами AMD 29000. Один из процессоров предназначен для передачи пакетов (то есть выполняет функции коммутации), а другой осуществляет администрирование - фильтрацию на портах концентратора в соответствии с масками, введенными администратором, и управляет всей логикой работы концентратора. Оба процессора имеют доступ к общей памяти объемом 4 МБ.

Как уже отмечалось, модуль обработки пакетов коммутатора ES/1 построен на сдвоенной процессорной архитектуре, причем каждый из процессоров отвечает за свои функции. Однако в случае отказа одного из них второй процессор возьмет на себя все функции первого. При этом коммутатор в целом продолжит нормальную работу, может только несколько снизиться его производительность.

Адресная таблица концентратора позволяет сохранять до 8192 МАС-адресов.

Программное обеспечение, управляющее работой концентратора ES/1, дублируется в двух банках Flash-памяти. Во-первых, это позволяет производить upgrade новых версий программного обеспечения без прекращения выполнения концентратором своих основных функций по коммутации пакетов, а во-вторых, сбой при загрузке нового ПО из банка Flash-памяти не приведет к отказу концентратора, поскольку ПО из первого банка памяти останется в рабочем состоянии, и концентратор автоматически перезагрузит его.

В слоты концентратора вставляются сетевые коммуникационные модули, при этом реализована технология автоматической самоконфигурации plug-and-play. Каждый модуль оснащен собственным RISC-процессором, который преобразует приходящие пакеты в протокольно-независимый вид (это означает, что сохраняются только блок данных, адреса приемника и источника, а также информация о сетевом протоколе) и передает их далее по внутренней шине в блок обработки пакетов.

Отказоустойчивость работы модулей обеспечивается наличием в каждом из них специального сенсора, посылающего предупреждение на консоль оператора при приближении температуры к критической отметке. Это может произойти, например, по причине запыления воздушных фильтров. Если температура продолжает повышаться и превышает второе пороговое значение, модуль автоматически отключается от питания для предотвращения выхода из строя элементной базы. При снижении температуры модуль автоматически продолжит работу.

Важной особенностью концентратора ES/1 является встроенная система защиты от "штормов" широковещательных пакетов (broadcast storm). Программное обеспечение концентратора ES/1 позволяет установить предельную частоту прихода таких пакетов на каждый порт концентратора, в случае превышения которой широковещательные пакеты перестают передаваться в другие сегменты сети, что сохраняет их работоспособность.

Фильтрация и виртуальные рабочие группы

С помощью механизма маскирования портов администратор может создавать виртуальные рабочие группы с целью защиты от несанкционированного доступа и повышения производительности ЛВС путем перераспределения информационных потоков. Фильтрацию можно включать на входящие и/или выходящие пакеты, по MAC-адресу или по всему сегменту и так далее. Всего маска может содержать до 20-ти условий, объединенных булевыми операндами "AND" и "OR". Понятно, что каждый пакет, приходящий на порт коммутатора, должен быть дополнительно проверен на соответствие условиям фильтрации, что требует дополнительных вычислительных ресурсов и может привести к снижению производительности. То, что в ES/1 один из двух процессоров выделен для проверки условий фильтрации, обеспечивает сохранение высокой производительности коммутатора при введенных администратором масках.

Наряду с отказами оборудования, ошибки обслуживающего персонала могут нарушить корректную работу ЛВС. Поэтому особо отметим еще один интересный режим виртуальной фильтрации коммутатора ES/1. В этом режиме фильтрация физически не включается, однако ведется набор статистики пакетов, удовлетворяющих условиям фильтрации. Это дает возможность администратору ЛВС заранее прогнозировать свои действия перед физическим включением фильтров.

Коммуникационные модули концентратора ES/1

ES/1 поддерживает до пяти модулей. Можно выбрать любую комбинацию модулей для Ethernet, Token Ring и FDDI, а также для высокоскоростных линий T1/E1 и T3/E3. Все модули, включая источники питания, могут заменяться без отключения от сети и выключения питания центрального устройства. Каждый модуль поддерживает набор конфигурируемых параметров для улучшения управляемости и собирает статистику.

QEIOM (Quad Ethernet I/O Module)

К этому модулю можно подключить до четырех независимых сегментов Ethernet. Каждый сегмент может передавать и получать информацию с обычной для Ethernet производительностью 14880 пакетов в секунду. ES/1 обеспечивает связь между этими четырьмя сегментами по типу мостов и маршрутизаторов, а также и со всей остальной сетью. Эти модули поставляются с различными типами разъемов: AUI, BNC, RJ-45 (витая пара) и ST (оптоволоконный кабель).

QTIOM (Token Ring I/O Module)

Через модуль QTIOM подключается до четырех 4 или 16 Mб/c сетей Token Ring. Модуль поддерживает все основные протоколы сети Token Ring - IBM Source Routing, Transparent Bridging и Source Routing Transparent - и обеспечивает "прозрачное" взаимодействие сетей Token Ring с сетями остальных типов, например Ethernet или FDDI. Модуль поставляется в вариантах для экранированной и неэкранированной витой пары.

IFIOM (Intelligent Dual-Attached FDDI I/O Module)

Модуль IFIOM подключает волоконно-оптический сегмент сети FDDI к ES/1 и обеспечивает прозрачное взаимодействие между разными типами сетей. Он поддерживает все функции FDDI-станции с двойным подключением к кольцу (Dual Attached Station). Этот модуль также поддерживает внешний оптический переключатель (Optical Bypass Switch), что обеспечивает повышенную отказоустойчивость сети при аварийном отключении ES/1. Поставляется в различных модификациях: для одномодового и многомодового волокна и в их комбинациях.

CEIOM24 (24-Port Concentrator Ethernet I/O Module)

Этот модуль включает в себя 24-портовый концентратор Ethernet на витой паре. Он увеличивает производительность сети при стоимости, меньшей, чем стоимость аналогичного внешнего устройства. Его порты сгруппированы в единый независимый сегмент Ethernet и взаимодействуют с другими модулями через коммутатор/маршрутизатор ES/1.

HIOM (High-Speed Serial Interface I/O Module)

HIOM позволяет осуществить подключение сетей к удаленным ЛВС по высокоскоростным линиям связи по протоколу HSSI со скоростью до 52 Мб/с. Поддерживается протокол PPP.

SNMP-управляемость

Модульный концентратор ES/1 может управляться с помощью любой стандартной системы управления, базирующейся на SNMP-протоколе, в том числе: HP OpenView, IBM NetView/6000, Sun NetManager и др. Для графического представления передней панели концентратора к перечисленным консолям управления добавляются специальные программные модули компании SMC семейства EliteView. Кроме того, имеется версия программного обеспечения мониторинга и управления, работающая под Windows: EliteView for Windows.

Типовые схемы использования концентратора ES/1

Создание вырожденной магистрали (Collapsed Backbone)

Вырожденная магистраль внутри коммутатора применяется в крупных корпоративных сетях. Несколько крупных сегментов локальной сети подключаются к портам концентратора, шина которого в этом случае выполняет роль основной магистрали с пропускной способностью в сотни Мб/с. Такой подход позволяет увеличить пропускную способность сети в несколько раз по сравнению с традиционным использованием мостов на каждом сегменте сети. При этом существенно повышаются возможности централизованного управления всеми элементами корпоративной сети.

Выделенный канал Ethernet (Dedicated Ethernet)

Эта схема подключения устройств к портам коммутируемых концентраторов применяется чаще всего для создания высокоскоростной магистрали (с гарантированной пропускной способностью 10 Мб/с) между концентратором и сервером локальной сети (обычно файловым сервером или сервером баз данных). Модульные концентраторы позволяют организовать при необходимости подключение сервера по высокоскоростному каналу FDDI или Fast Ethernet.

Транслирующая коммутация

Коммутация в ES/1 основана на синхронной протокольно-независимой технологии (Synchronous Protocol Independent technology), которая поддерживает основные технологии локальных сетей, позволяя осуществлять трансляцию между кадрами различных форматов. Поэтому коммутатор ES/1 может использоваться для соединения сетей различных типов - Ethernet, Token Ring, FDDI, причем трансляция происходит со скоростью коммутации и не создает перегрузок трафика при межсетевых передачах.

Образование виртуальных групп

По умолчанию коммутатор работает в режиме моста, изучая трафик, проходящий через его порты и строя таблицу адресов сегментов. С помощью программного обеспечения EliteView администратор может в удобной графической форме определить состав виртуальных рабочих групп, куда будут входить либо локальные сегменты, если к порту ES/1 подключен концентратор или сегмент Ethernet на коаксиальном кабеле, либо отдельные рабочие станции, если они подключены к порту индивидуально выделенным каналом. Виртуальные рабочие группы могут включать различные порты как одного, так и нескольких коммутаторов ES/1.

Виртуальные сети

Наряду с образованием виртуальных изолированных рабочих групп, защищающих данные и локализующих трафик, очень полезным свойством коммутатора является возможность объединения этих групп в интерсеть с помощью внутренней маршрутизации пакетов между виртуальными сегментами, которые объявляются виртуальными сетями (IP или IPX). При этом передача пакетов между портами, принадлежащими одной сети, происходит быстро на основании коммутации пакетов, в то же время пакеты, предназначенные другой сети, маршрутизируются. Таким образом, обеспечивается взаимодействие между виртуальными рабочими группами, и в то же время выполняются все функции по защите сетей друг от друга, обеспечиваемые маршрутизаторами.


Коммутаторы локальных сетей компании 3Com

Компания 3Com занимает прочные позиции на рынке коммутаторов, выпуская широкий спектр этих устройств для всех областей применения.

Сектор коммутаторов для настольных применений и рабочих групп представляют коммутаторы семейства Link Switch. Коммутаторы для сетей отделов и магистральные коммутаторы представлены семейством LANplex. Для сетей АТМ компания выпускает коммутаторы семейства CELLplex.

Технология коммутация неэффективна без опоры на специализированные БИС -ASIC, которые оптимизированы для быстрого выполнения специальных операций. Компания 3Сom строит свои коммутаторы на нескольких ASIC, разработанных для коммутации определенных протоколов.

  • ASIC ISE (Intelligent Switching Engine) предназначена для выполнения операций коммутации Ethernet и FDDI, а также поддержки функций маршрутизации и управления. Используется в коммутаторах LANplex 2500, LANplex 6000 и LinkSwitch 2200.
  • ASIC TRSE (Token Ring Switching Engine) выполняет коммутацию сетей Token Ring. Используется в коммутаторах LinkSwitch 2000 TR и LANplex 6000.
  • ASIC BRASICA выполняет коммутацию Ethernet/Fast Ethernet. Поддерживает технологию виртуальных сетей и спецификацию RMON. Используется в коммутаторах LinkSwitch 1000 и LinkSwitch 3000.
  • ASIC ZipChip поддерживает коммутацию ATM, а также преобразование кадров Ethernet в ячейки АТМ. используется в коммутаторах CELLplex 7000 и LinkSwitch 2700.

В следующей таблице приведены основные параметры коммутаторов семейства LinkSwitch.

Модель | LS 500 | LS 1000 | LS 1200 | LS 2200 | LS 2700 | LS 3000
Высокоско- ростной порт | Нет | 100Base-T | FDDI | FDDI | ATM | 100Base-T
Общая производительность | 50 Мб/с | 220 Мб/с | 60 Мб/с | 130 Мб/с | 120 Мб/с | 310 Мб/с
Цена | $5100 | $5850 | $8220 | $11750 | $10800 | $12800
Цена за порт | $510 | $244 | $1370 | $735 | $900 | $2560
Кол. портов | 10 | 24+1(2) | 6 + 1 | 16 + 1 | 12 + 1 | 5
Количество MAC-адресов | 8000 | 500 | 1016 | 8000 | 8200 | 4000
Метод продвижения | CT | CT, S&F | S&F | S&F | CT, S&F | S&F

Примечания: СT - режим "на лету" (cut-through); S&F - с буферизацией (store-and-forward).

Коммутатор LANplex 6012 представляет собой старшую модель коммутатора локальных сетей, предназначенную для работы на уровне магистрали корпоративной сети.

Структурная схема коммутатора LANplex 6012 приведена на рисунке 7.2.

Структура коммутатора до сих пор выдает ориентацию его ранних версий на коммутацию FDDI/Ethernet. До появления модулей, выходящих на высокоскоростную протокольно-независимую шину HSI, коммутатор использовал шины FDDI для межмодульного обмена.

Основные характеристики коммутатора LANplex 6012:

  • Устройство управления (отдельный модуль) поддерживает SNMP, RMON и FDDI SMT;
  • Виртуальные сети создаются на основе:
  • группирования портов;
  • группирования МАС-адресов.
  • Поддерживается IP и IPX маршрутизация (RIP):
  • несколько подсетей на один порт;
  • несколько портов на одну подсеть.
  • IP- фрагментация;
  • ASIC+RISC процессоры;
  • Наличие функции Roving Analysis Port позволяет наблюдать за трафиком любого порта коммутатора;
  • Поддержка алгоритма Spanning Tree;
  • Фильтрация широковещательного шторма.

Рис. 7.2. Коммутатор LANplex 6012


Примеры АТМ-коммутаторов для локальных сетей

Коммутаторы CELLplex компании 3Com

Коммутатор CELLplex 7000 представляет собой модульное устройство на основе шасси, осуществляющее коммутацию до 16 портов ATM (4 модуля по 4 порта). Он предназначен для образования высокоскоростной ATM-магистрали сети путем соединения с другими ATM-коммутаторами или же для подключения высокоскоростных ATM-узлов к стянутой в точку магистрали сети на основе центра данных, имеющего порт ATM.

Коммутационный центр обеспечивает обмен данными по схеме 16(16, используя неблокирующую технологию коммутации "на лету" с общей пропускной способностью 2.56 Гб/с и поддерживая до 4096 виртуальных каналов на порт.

Пассивная внутренняя шина коммутатора обеспечивает передачу данных со скоростью до 20.48 Гб/с, обеспечивая переход в будущем на интерфейсные модули с большим количеством портов или с более скоростными портами.

Полностью избыточное шасси со сдвоенным источником питания, продублированным коммутационным центром и модульное построение делают коммутатор CELLplex 7000 отказоустойчивым устройством, подходящим для построения магистрали сети и удовлетворяющим требованиям наиболее важных приложений.

Имеются два типа интерфейсных модулей:

  • модуль с 4 портами OC-3c 155 Мб/с для многомодового оптоволоконного кабеля, предназначенный для локальных связей;
  • модуль с 4 портами DS-3 45 Мб/с - для глобальных связей.

Коммутатор поддерживает основные спецификации технологии ATM: установление коммутируемых виртуальных каналов (SVC) по спецификациям UNI 3.0 и 3.1, поддержку постоянных виртуальных каналов (PVC) с помощью системы управления, Interim Interswitch Signaling Protocol (IISP), эмуляцию локальных сетей (LAN emulation), управление перегрузками (congestion management).

Управление коммутатором реализовано для стандартов: SNMP, ILMI, MIB 2, ATM MIB, SONET MIB. Используется система управления Transcend.

Коммутатор CELLplex 7200 совмещает функции ATM-коммутатора и Ethernet-комму-
татора, одновременно позволяя ликвидировать узкие места на магистрали сети и в сетях отделов.

CELLplex 7200 обеспечивает полноскоростные Ethernet-каналы для разделяемых сегментов локальных сетей, серверов и отдельных рабочих станций, требующих повышенного быстродействия. Кроме этого, коммутатор может быть сконфигурирован с портами ATM для соединения с коммутаторами рабочих групп, ATM-серверами и рабочими станциями, а также для подключения к ATM-магистрали сети.

Коммутационный ATM-центр (8(8) совмещен с процессором Ethernet/ATM коммутации на микросхеме ZipChip. ZipChip преобразует пакеты данных Ethernet в стандартные ячейки ATM, а затем коммутирует их со скоростью до 780000 ячеек в секунду.

В отличие от модели CELLplex 7000 модель CELLplex 7200 имеет не два, а четыре типа интерфейсных модулей:

  • модуль с двумя портами ATM OC-3c;
  • модуль с двумя портами DS-3;
  • модуль с 12 портами Ethernet и одним портом ATM OC-3c;
  • модуль с 12 портами Ethernet и одним портом ATM DS-3.

Остальные характеристики коммутаторов CELLplex 7200 и CELLplex 7000 практически совпадают.

Коммутаторы технологии ATM LattisCell и EtherCell компании Bay Networks

Семейство продуктов, разработанных компанией Bay Networks для технологии ATM, состоит из коммутаторов LattisCell (только ATM-коммутация), коммутатора EtherCell (коммутация Ethernet-ATM), программного обеспечения ATM Connection Management System и программного обеспечения ATM Network Management Application.

Поставляется несколько моделей коммутаторов ATM, каждый из которых обеспечивает определенное сочетание физических уровней, сред передачи и возможностей резервирования источников питания.

Коммутатор EtherCell предназначен для устранения "узких мест" в рабочих группах локальных сетей, использующих традиционную разделяемую среду передачи данных технологии Ethernet. С помощью этого коммутатора можно разгрузить линии связи с серверами и маршрутизаторами. Модель 10328 EtherCell имеет 12 портов 10Base-T и прямой доступ к сети ATM. Порты Ethernet могут предоставлять выделенную полосу пропускания 10 Мб/с за счет их коммутации.

Программное обеспечение ATM Connection Management System (CMS) размещается на рабочей станции SunSPARCStation, выполняя функции координации и управления соединениями коммутатора. CMS автоматически изучает сетевую топологию и устанавливает виртуальные ATM-соединения между взаимодействующими станциями.

Программное обеспечение ATM Network Management Application, работая совместно с CMS, обеспечивает управление сетью ATM на центральной станции управления.

Модель ATM коммутатора LattisCell 10114A разработана для использования в сетях кампусов (расстояние между коммутаторами до 2 км) и представляет собой устройство, выполненное в виде автономного корпуса с фиксированным количеством портов, число которых равно 16. Для каждого порта обеспечивается пропускная способность в 155 Мб/с по многомодовому оптоволоконному кабелю. Функции физического уровня реализованы в соответствии со стандартами SONET/SDH 155 Мб/с, а также UNI 3.0

Архитектура FastMatrix обеспечивает общую внутреннюю скорость передачи данных 5 Гб/с, позволяющую производить коммутацию всех портов без блокировок. Поддерживаются функции широковещательной (broadcast) и многовещательной (multicast) передачи.

Запрос на установление соединения может быть выполнен для различных уровней качества сервиса (Quality of Service, QoS):

  • QoS 1 - используется для сервиса CBR (постоянная битовая скорость);
  • QoS 2 - используется для сервиса VBR RT (переменная битовая скорость приложений реального времени);
  • QoS 3/4 - используется для сервиса VBR, предназначенного для передачи данных локальных сетей по процедурам с установлением соединений и без установления соединений;
  • QoS 0 - используется для сервиса UBR.

Управление устройством осуществляется также с помощью программной системы CMS, для которой необходимы: SunSPARCStation 2 или выше, Sun OS 4.1.3 или выше для невыделенного Ethernet-соединения или Solaris 2.4 для прямого ATM-соединения.

Другие модели коммутаторов LattisCell (10114R, 10114A-SM, 10114R-SM, 10114R-SM, 10114-DS3, 10114-E3, 10115A, 10115R) различаются наличием резервного источника питания, а также типом портов (общее количество портов в любой модели составляет 16). Кроме многомодовых портов, коммутаторы могут иметь одномодовые оптоволоконные порты (для сетей кампусов с расстоянием до 25 км), а также порты для коаксиального кабеля с интерфесами DS-3 (45 Мб/с) и E3 (34 Мб/с) для подключения к глобальным сетям через линии T3/E3.

Модели коммутатора EtherCell (10328-F и 10328-SM) обеспечивают коммутацию Ethernet-Ethernet и Ethernet-ATM. Эти модели имеют 12 портов 10Base-T RJ-45 и один порт прямого доступа к ATM со скоростью 10 Мб/с. Порты 10Base-T могут использоваться для предоставления полной скорости 10 Мб/с выделенной линии для высокоскоростных серверов или же для разделения ее между сегментом станций рабочей группы.

Модель EtherCell 10328-F поддерживает многомодовый оптоволоконный кабель для связи с сетью ATM на расстоянии до 2 км.

Модель EtherCell 10328-SM поддерживает одномодовый оптоволоконный кабель для связи с сетью ATM на расстоянии до 20 км.

Коммутаторы поддерживают стандарт LAN emulation, определяющий взаимодействие локальных сетей с сетями ATM на уровне протоколов канального уровня. Кроме этого, поддерживаются спецификации UNI, MIB-II, EtherCell-MIB и стандартный формат MIB компании Bay Networks.

Через ATM-порт коммутаторы EtherCell могут соединяться с портом SONET/SDH коммутатора LattisCell.

Коммутаторы EtherCell включают программу-агент HSA (Host Signaling Agent), которая является агентом-посредником для Ethernet-хостов.

Коммутаторы EtherCell поддерживают образование виртуальных групп, распределенных по ATM-магистрали сети, образованной коммутаторами LattisCell.

Коммутатор LightStream 1010 компании Cisco

Коммутатор LightStream 1010 является ATM коммутатором для образования магистралей сетей отделов или кампусов.

Коммутатор обладает общей производительностью 5 Гб/с и выполнен на базе 5-слотового шасси.

В центральном слоте устанавливается модуль управления коммутацией ATM Switch Processor (ASP), который имеет разделяемую память со скоростью доступа 5 Гб/с, полностью неблокирующую коммутационную матрицу, а также высокопроизводительный RISC-процессор MIPS R4600 100 MHz. Модуль ASP работает под управлением межсетевой операционной системы IOS, как и маршрутизаторы и коммутаторы старших моделей компании Cisco. Программное обеспечение модуля ASP может заменяться "на ходу", то есть без остановки коммутатора, что важно в условиях часто изменяющихся спецификаций ATM Forum.

Оставшиеся 4 слота используются для установки интерфейсных модулей CAM, в каждый из которых можно установить до 2-х модулей адаптеров портов PAM. Таким образом, коммутатор может иметь в максимальной конфигурации до 8 модулей PAM из следующего набора:

  • 1 порт ATM 622 Мб/с (OC12) (одномодовый);
  • 1 порт АТМ 622 Мб/с (OC12) (многомодовый);
  • 4 порта ATM 155 Мб/с (OC3с) (одномодовый);
  • 4 порта ATM 155 Мб/с (OC3с) (многмодовый);
  • 4 порта ATM 155 Мб/с (OC3с) (по неэкранированной витой паре UTP Cat 5);
  • 2 порта DS3/T3 45 Мб/с;
  • 2 порта E3 34 Мб/c.

Коммутатор LightStream 1010 одним из первых в отрасли поддерживает спецификацию маршрутизации PNNI Phase 1, необходимую для маршрутизации коммутируемых соединений (SVC) в неоднородных АТМ-сетях с учетом требуемого качества обслуживания.

Поддерживаются все определенные ATM Forum виды трафика, в том числе ABR.

Для соединений "пользователь - коммутатор" используется протокол UNI 3.0 (в ближайшее время ожидается также поддержка UNI 3.1).

Коммутатор LightStream 1010 может выполнять роль центрального коммутатора в сети кампуса (рисунок 7.3).

Рис. 7.3. Магистральная сеть Московского государственного университета


Тестовые испытания коммутаторов

Поскольку коммутаторы постоянно расширяют свою сферу деятельности, то интерес, проявляемый к ним со стороны различных тестовых лабораторий не уменьшается. В основном тестируются различные характеристики производительности для типовых конфигураций сети.

Проводимые тестовые испытания интересны в двух аспектах. Во-первых, интересны сами результаты испытаний, хотя абсолютизировать их ни в коем случае нельзя. Если один коммутатор превзошел другой по определенному показателю при определенных условиях на 10% или 20%, то это совершенно не значит, что в других условиях второй коммутатор не покажет себя лучше на 15%. В то же время существенное отставание от общей массы моделей какого-либо коммутатора должно насторожить его потенциальных покупателей.

Во-вторых, интересны создаваемые условия тестирования, так как они обычно выбираются на основании опыта эксплуатации коммутаторов и соответствуют наиболее тяжелым режимам их работы.

Ниже описываются условия и приводятся результаты тестирования коммутаторов, проведенные совместно тестовой лабораторией журнала Data Communication и European Network Labs. При получении первых результатов тестирования они обсуждались с представителями компаний-производителей, в результате чего в программное обеспечение некоторых моделей были внесены изменения, улучшившие их работу в специфических условиях проводимых испытаний.

Тестировались коммутаторы в конфигурации с распределенной магистралью, когда большое количество портов Ethernet 10 Мб/c обменивается данными через магистраль Fast Ethernet или FDDI.

Схема экспериментальной сети представлена на рисунке 8.1.

Рис. 8.1. Схема тестирования коммутаторов

Нагрузка на сеть создавалась двумя генераторами трафика Smartbits Advanced SMB100, которые посылали трафик на 20 портов Ethernet каждого из двух тестируемых образцов коммутатора. Трафик, посылаемый на каждый входной порт, направлялся через этот порт остальным 39 портам коммутаторов с равной степенью вероятности во всех тестах, кроме теста на вносимую задержку, где трафик просто пропускался в одном направлении через магистраль. Использовались кадры минимального размера по 64 байта каждый.

Генераторы трафика подсчитывали количество кадров, которые дошли до порта назначения и на основании этих данных подсчитывались количественные оценки качества передачи трафика коммутаторами.

Тестировалось достаточно много моделей коммутаторов, параметры которых приведены в следующей таблице.

Наименование коммутатора | Режим "на лету" |  | Полнодуплексные Ethernet/FDDI/ Fast Ethernet |  | Макс. число портов Ethernet/ FDDI/ Fast Ethernet |  | Макс. число портов Ethernet в стеке
Bay Networks LattisSwitch 28115 |  | Нет |  | Да/-/Да |  | 16/-/18 |  | 487
Cisco Systems Catalist 5000 |  | Нет |  | Да/Нет/Да |  | 96/4/50 |  | -
Cisco Systems 2800 |  | Да |  | Нет/Нет/Да |  | 25/2/16 |  | -
Digital Equipment DECswitch 900EF + GIGAswitch |  | Нет |  | Нет/Да/- |  | 12/7/- |  | 150
Madge Networks LANswitch с модулями LFE 100, LSE 404S и LSE 808 |  | Нет |  | Да/-/Нет |  | 112/8/16 |  | -
3Com LANplex 6004 |  | Нет |  | Нет/Да/- |  | 48/6/- |  | -
3Com Linkswitch 1000 |  | Да |  | Нет/-/Да |  | 24/-/2 |  | 192

Продолжение таблицы

Наименование коммутатора | Максимальное кол-во MAC-адресов на порт | Фильтрация ошибочных кадров (FCS, allignment, jubber, runts) | Поддержка RMON | Интегрированное наблюдение за трафиком
Bay Networks LattisSwitch 28115 | 1024 | Все типы локально и через магистраль | Нет | Нет
Cisco Systems Catalist 5000 | 1333 | Все типы локально и через магистраль | Да | Да
Cisco Systems 2800 | 2042 на коммутатор | Все типы через магистраль, но не локально | Нет | Да
Digital Equipment DECswitch 900EF + GIGAswitch | 1333 | Все типы локально и через магистраль | Все 9 групп | Нет
Madge Networks LANswitch | 64000 | Все типы кроме FCS ло- кально и через магистраль | Все 9 групп | Да
3Com LANplex6004 | 8192 | Все типы локально и через магистраль | Statistics, history, alarm, event | Да
3Com Linkswitch 1000 | 19 | Все типы через магистраль, но не локально | Statistics, history, alarm, host, host top N, matrix, event | Да, через встроенный RMON

Тест 1. Коммутация пульсаций трафика

В первом тесте проверялась способность коммутатора передавать без потерь кратковременные пульсации трафика.

Условия эксперимента: подача на каждый порт пачки из 24 кадров, пауза в 1 секунду, подача на каждый порт пачки из 62 кадров, пауза в 1 секунду, и так далее при увеличении размера пачки до 744 кадров. Каждая пачка создавала 100% загрузку каждого из 40 портов Ethernet, участвовавших в тестировании.

Результаты тестирования:

Коммутатор LANplex при первых испытаниях потерял достаточно большой процент кадров, после чего специалисты компании 3Сom внесли коррективы в его программное обеспечение и повысили степень агрессивности портов коммутатора. В результате коммутатор перестал терять кадры.

Во втором тесте проверялась максимальная пропускная способность коммутации в расчете на один порт при 100% кратковременной загрузке порта.

Условия эксперимента: генерировалась пачка из 24 кадров для каждого порта и измерялась максимальная скорость доставки кадров в порт назначения.

Результаты тестирования:

Наилучшие результаты показал коммутатор Catalist 5000, передавая почти 5000 кадров в секунду при максимальной теоретически возможной пропускной способности в 7440 кадров в секунду (учитывались только принимаемые потом кадры). Значительное снижение реальной пропускной способности по сравнению с максимально возможной отражает трудности, которые испытывает коммутатор при полудуплексном режиме работы, одновременно передавая и принимая кадры. Коммутатор LANplex несколько отстал от лидера, что специалисты, проводившие тестирование, объясняют слишком высоким уровнем агрессивности, установленном для предотвращения потерь кадров. Такой уровень слишком "тормозит" конечный узел, не давая ему развить более высокую скорость выдачи кадров в сеть.

В третьем тесте оценивалась задержка, вносимая коммутатором при передаче кадра через магистраль

Условия эксперимента: Постоянный однонаправленный поток кадров через магистраль. Измерялось время между поступлением первого бита кадра на входной Ethernet-порт первого коммутатора и появлением первого бита этого же кадра на выходном Ethernet-порту второго коммутатора.

Результаты тестирования:

Коммутаторы, которые использовали в качестве магистрали кольцо FDDI, вносили большие задержки по сравнению с коммутаторами, связанными по магистрали Fast Ethernet. Это не удивительно, так как в последнем случае трансляция кадров не выполнялась.